[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Scheme-reports] Bytevectors should be called u8vectors
-----BEGIN PGP SIGNED MESSAGE-----
On 07/01/2012 01:23 AM, Marc Feeley wrote:
> Formal Comment
> Submitter's name: Marc Feeley
> Submitter's email: feeley at iro.umontreal.ca
> Relevant draft: r7rs draft 6
> Type: defect
> Priority: minor
> Relevant section of draft: 6.9. Bytevectors
> Summary: Bytevectors should be called u8vectors
> Many implementations of Scheme have adopted SRFI-4 where bytevectors
> are called u8vectors, and where the procedures operating on
> bytevectors have u8vector in their name.
> I see no reason to introduce new names. It will require many
> implementations to implement the new names, and moreover the SRFI-4
> names will have to be kept for code which uses SRFI-4. This is
> needless bloat.
> The name u8vector is a very mnemonic way of expressing verbally the
> external representation #u8(...) which is used by R7RS for
> I also find the names bytevector-u8-ref and bytevector-u8-set!
> very clumsy and verbose compared to u8vector-ref and u8vector-set!.
FWIW, my take on this is that we should have called them either "blobs"
(that being a region of memory which has not particular implied
structure; if it's actually a sequence of IEEE floats, then unsigned
8-bit bytes isn't actually a particularly useful view of them), or if we
go for the "they are unsigned 8-bit bytes" model, call them u8vectors...
I was a bit sad that "bytevector" won out.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
-----END PGP SIGNATURE-----
Scheme-reports mailing list